Follow us on Facebook
Current Students
Prospective Students
Faculty & Staff

Browser Recommendations

Most computer systems come with a browser, the program used to access the Internet, already installed. Windows machines come with Internet Explorer (IE), Mac computers come with Safari. However, both of these programs have several problems. IE has consistently demonstrated a number of security weaknesses, while Safari may have some compatibility problems with Blackboard. Technical Support recommends Firefox which is available as a free download.


Firefox is an open source browser available from Mozilla Corp. It has received over 35 "best" awards from organizations such as PC Magazine, CNET, Info World, Linux Journal, Forbes, PC Pro, and Macworld, is one of the fastest browsers available, is available in 71 languages, and is used in every country in the world. Firefox is fully compatible with Blackboard, Hawklink, Collaborate, TU email, and has over 6,000 plug-ins and add-ons available to customize your browsing experience to best suit your needs. Firefox is also recognized as being one of the most secure browsers and is available for Windows, Mac, and Linux platforms.


Chrome is the fast, sleek new browser from Google. Technical Support wants you to be aware that Chrome is not compatible with Collaborate. It is also not available for Mac or Linux. If you use Chrome as your primary browser, we recommend you also download and install Firefox as a back-up browser for use with Collaborate.

Browser help

In order to access Blackboard and Collaborate, please be sure to configure your browser to the settings below. Selecting the Medium security setting will work in most cases.

  • Java enabled
  • JavaScript enabled
  • Cookies enabled
  • Allow pop-ups from Collaborate and Blackboard

If you have a technical issue with a browser, check the following resources.

  • Blackboard provides tables of browser compatibility to assist you. Be sure to check if you are experiencing a problem.
  • Collaborate provides a software check for first-time users. We recommend you use this tool each time you upgrade to a new browser version.

If this does not resolve your problem, we recommend you roll-back your browser to an earlier supported version. 

Education that Engages... Empowers... TRANSFORMS

nimblecmsan NTS product